os/home.nix
2024-09-30 22:43:48 +02:00

126 lines
3.0 KiB
Nix

{config, lib, pkgs, inputs, ...}: {
imports = [
./programs/firefox.nix
./programs/tmux.nix
./programs/bash.nix
];
home.stateVersion = "22.05";
home.packages = with pkgs; [
bat
bottom
dino
direnv
element-desktop
endeavour
eza
fd
file
foliate
fortune
fragments
git
gparted
htop
inkscape
lf
libreoffice
minetest
mpv
mumble
neovim
nextcloud-client
nix-direnv
nodejs-18_x
obs-studio
openvpn
pinta
prismlauncher
ripgrep
sequeler
skim
sqlite
sqlite.dev
stack
steam-run
syncplay
tdesktop
thunderbird
tmux
tuba
ungoogled-chromium
unzip
vim
vscodium
wget
widevine-cdm
wl-clipboard
zip
zotero
thunderbird
signal-desktop
entr
pandoc
texliveFull
];
programs.home-manager.enable = true;
dconf.settings = {
"org/gnome/desktop/wm/keybindings" = {
move-to-workspace-left = ["<Alt><Super>Left"];
move-to-workspace-right = ["<Alt><Super>Right"];
switch-to-workspace-left = ["<Super>Left"];
switch-to-workspace-right = ["<Super>Right"];
switch-applications = ["<Super>Tab"];
switch-applications-backward = ["<Shift><Super>Tab"];
switch-windows = ["<Alt>Tab"];
switch-windows-backward = ["<Shift><Alt>Tab"];
};
"org/gnome/settings-daemon/plugins/media-keys" = {
custom-keybindings = ["/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/"];
};
"org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0" = {
binding = "<Super>t";
command = "kgx";
name = "gnome-console";
};
"org/gnome/desktop/interface" = {
clock-show-weekday = true;
};
"org/gnome/desktop/peripherals/touchpad" = {
tap-to-click = true;
two-finger-scrolling-enabled = true;
};
"org/gnome/shell" = rec {
enabled-extensions = [
"trayIconsReloaded@selfmade.pl"
"AlphabeticalAppGrid@stuarthayhurst"
"clipboard-history@alexsaveau.dev"
"noannoyance@daase.net"
];
# disabled-extensions = builtins.filter (x: ! builtins.elem x enabled-extensions) disabled-extensions;
favorite-apps = [
"firefox.desktop"
"chromium-browser.desktop"
"org.gnome.Console.desktop"
"org.gnome.Nautilus.desktop"
"thunderbird.desktop"
"signal-desktop.desktop"
"element-desktop.desktop"
"org.telegram.desktop.desktop"
"im.dino.Dino.desktop"
];
};
"org/gnome/desktop/background" = {
"picture-uri" = "${config.home.homeDirectory}/.background-image";
};
};
home.file.".background-image".source = "${./.}/Morskie Oko.jpg";
}